Соберите, пожалуйста, пакет ...

Используем пакеты, расширяющие возможности оборудования
Аватара пользователя
Zyxmon
Администратор
Сообщения: 1774
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 23 авг 2015, 07:06

В этой теме оставляйте Ваши заявки.
Приблизительный шаблон:
---------------------------------------
Соберите, пожалуйста, пакет XXX, версия YYY.
Ссылка на исходники - http:://
Пакет (есть, нет, не знаю) в Openwrt.

Я использую железку ZZZ с Entware.mipsel фид mipselsf
Готов протестировать
-------------------------------------

Аватара пользователя
TheBB
Сообщения: 92
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.098,43.022

Сообщение TheBB » 03 мар 2020, 20:58

Код: Выделить всё

opkg install http://bin.entware.net/mipselsf-k3.4/test/crelay_0.13-1_mipsel-3.4.ipk

тестим-отписываемся
K Giga II NDMSv.2.06C/2.11D/2.15A + Entware-Keenetic/Entware&Gentoo; K DSL NDMSv.2.05C/2.11D + Entware-Keenetic/Entware&Debian 8.11/9.6

isvlad
Сообщения: 7
Зарегистрирован: 04 янв 2016, 21:32

Сообщение isvlad » 07 мар 2020, 18:14

TheBB писал(а):Источник цитаты тестим-отписываемся


Переустановил Entware? Поставил crelay. Заработало ! :) Большое спасибо!!! Единственно момент. Собирали из https://github.com/ondrej1024/crelay ? Дело в том, что 13 версия глючная слегка. У автора вроде как 14 выложена.

SerZ
Сообщения: 1
Зарегистрирован: 16 мар 2020, 20:19

Сообщение SerZ » 16 мар 2020, 21:05

Собрал для себя node.js посвежее, может ещё кому пригодится.

Собирал не из основной ветки OpenWrt, "по мотивам" nxhack/openwrt-node-packages - адаптировал эту репу под Entware, сделал свой Makefile (добавил поддержку 13.x версии, убрал поддержку 10.x версии).

Для работы обеих версий нужна libuv посвежее, чем в Entware:
libuv_1.35.0-1_mipsel-3.4.ipk
Сначала ставим пакет libuv_1.35.0-1_mipsel-3.4.ipk, потом ноду.

Текущая LTS:
node_v12.16.1-1_mipsel-3.4.ipk
node-npm_v12.16.1-1_mipsel-3.4.ipk

Current:
node_v13.12.0-1_mipsel-3.4.ipk
node-npm_v13.12.0-1_mipsel-3.4.ipk

Так же собрал оптимизированные по скорости пакеты - mipsel-устройства для ноды несколько "медленноваты".
Может быть в некоторых сценариях они будут чуть быстрее (не тестировал).
Но памяти им надо больше, сами они по размеру больше, соответственно и запускаться будут дольше.

npm брать "обычный" соответствующей версии.

"Оптимизированные" пакеты:
libuv_1.35.0-1_mipsel-3.4.ipk
node_v12.16.1-1_mipsel-3.4.ipk
node_v13.12.0-1_mipsel-3.4.ipk
Padavan@KN-ULTRA2

playtester
Сообщения: 4
Зарегистрирован: 24 дек 2018, 14:43

Сообщение playtester » Сегодня, 10:59

Соберите пожалуйста пакеты, готов потестировать. Устройства Keenetic II, Keenetic Onmi II, Keenetic Omni (KN-1410)
https://openwrt.org/packages/pkgdata_lede17_1/reaver
https://openwrt.org/packages/pkgdata_owrt18_6/pixiewps

Аватара пользователя
Александр Рыжов
Сообщения: 410
Зарегистрирован: 12 авг 2015, 13:14
Откуда: Смоленск

Сообщение Александр Рыжов » Сегодня, 11:39

playtester, зачем запускать утилиты для брутфорса на столь убогом MIPS-процессоре?
pixiewps, кстати, есть в репозитории, можете оценить скорость его работы.


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 1 посетитель :: 0 зарегистрированных, 0 скрытых и 1 гость (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (162) здесь было 16 ноя 2019, 17:33

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость